Einstellungen eines wifi Clients in openWrt

Für die Arbeit mit WiFi in openWrt gibt es das Skript /sbin/wifi. Die Datei /etc/config/wireless ist für die Konfiguration wifi verantwortlich.

Erstellen wir eine "default"-Konfigurationsdatei:

wifi detect > /etc/config/wireless

Die Datei sollte wie folgt aussehen:

config wifi-device  radio0 
	option type     mac80211 
	option channel  11 
	option hwmode	11g 
	option path	'pci0000:00/0000:00:1c.2/0000:05:00.0' 

	# REMOVE THIS LINE TO ENABLE WIFI: 
	option disabled 1 

config wifi-iface 
	option device   radio0 
	option network  lan 
	option mode     ap 
	option ssid     OpenWrt 
	option encryption none

Aktualisieren wir die Datei für unsere Konfiguration.
Die Datei /etc/config/wireless ist für ein offenes Netz:

config wifi-device  radio0 
	option type     mac80211 
	option channel  'auto' 
	option hwmode	11g 
	option path	'pci0000:00/0000:00:1c.2/0000:05:00.0' 
	option disabled 0 

config wifi-iface 
	option device   radio0 
	option network  wwan 
	option mode     sta 
	option ssid     testwifi
	option encryption none

Die Datei /etc/config/wireless ist für das verschlüsselte Netzwerk:

config wifi-device 'radio0' 
        option type 'mac80211' 
        option channel '6' 
        option hwmode '11ng' 
        option path 'pci0000:00/0000:00:1c.2/0000:05:00.0' 
        option disabled '0' 

config wifi-iface
        option device 'radio0' 
        option network 'wwan' 
        option mode 'sta' 
        option ssid 'testwifi' 
        option encryption 'psk2' 
        option key '1234567890'

sta — Client-Modus; ap — Access Point-Modus

Um die Adresse via dhcp automatisch zu erhalten, ist die Schnittstelle in der Datei /etc/config/network zu erstellen:

config interface wwan 
	option proto 'dhcp'

Führen wir Folgendes aus, um neue Einstellungen anzuwenden:

/etc/init.d/network restart

Auf der Konfigurationsstufe von openWrt ist wpa-supplicant auszuwählen, sonst kann wifi vom Skript openWrt /sbin/wifi nicht entstanden werden:

Network:
	<*> wpa-supplicant

Nach einem «wifi down» wird wifi ausgeschaltet und das Interface wlan0 verschwindet.

Nach einem «wifi up» entsteht das Interface wlan0 und es wird ans Netz angeschlossen.

Bei einer erfolgreichen Operation kann man folgenden Log auf dem Bildschirm sehen:

wifi up 
Successfully initialized wpa_supplicant
[   10.975345] iwl3945 0000:05:00.0: loaded firmware version 15.32.2.9 
[   14.670591] wlan0: authenticate with bc:ae:c5:c3:ab:d5 
[   14.673644] wlan0: send auth to bc:ae:c5:c3:ab:d5 (try 1/3) 
[   14.675760] wlan0: authenticated 
[   14.676031] iwl3945 0000:05:00.0: wlan0: disabling HT as WMM/QoS is not supported by the AP 
[   14.676335] iwl3945 0000:05:00.0: wlan0: disabling VHT as WMM/QoS is not supported by the AP 
[   14.680246] wlan0: associate with bc:ae:c5:c3:ab:d5 (try 1/3) 
[   14.682727] wlan0: RX AssocResp from bc:ae:c5:c3:ab:d5 (capab=0x401 status=0 aid=1) 
[   14.684368] wlan0: associated 

Möglicherweise kann ein Fehler entstanden werden (beim Fehlen von wpa-supplicant):

wifi up 
command failed: Device or resource busy (-16) 

Eine Netzverbindung wäre im manuellen Modus mit folgendem Befehl möglich:

iw dev wlan0 connect -w testwifi